Issues With Puzzles
Incident Report for Arkose Labs
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 23:37 UTC
Identified
We believe we have identified the issue and are validating resolution.
Posted Oct 10, 2024 - 23:31 UTC
Investigating
We are currently investigating an issue with Arkose Labs Puzzles. We will post an update as soon as possible.
Posted Oct 10, 2024 - 23:22 UTC
This incident affected: Regional Healthchecks (North Virginia Healthcheck, Oregon Healthcheck, Singapore Healthcheck, Ireland Healthcheck, Ohio Healthcheck, Sydney Healthcheck).