Potential degradation of Verify API

Incident Report for Arkose Labs

Resolved

The incident has been mitigated.
Posted May 25, 2023 - 16:47 UTC

Investigating

We have detected a potential degradation of the Verify API in the CN-NORTH-1 region. We are actively investigating the issue and will provide an update shortly.
Posted May 25, 2023 - 16:31 UTC